Blog

Server Requirements

setings

Server Requirements

To install Smart School, your web server must be running PHP 5.4 or higher and Mysql 5.1 or higher. We have tested it with Windows, Mac and Linux but for optimum performance we will recommend to use Linux with Apache webserver. Below are a list of items you should ensure your host can comply with –

  • PHP 5.6+
  • MYSQL 5.1+
  • MYSQL SQL_MODE must not contain ONLY_FULL_GROUP_BY
  • mod_rewrite Apache
  • MBString Extension
  • MYSQLi Extension
  • fileinfo Extension
  • Zip Extension
  • CURL Extension (recommended)
  • PHP max_execution_time should be atleast 60 seconds for smoother installation

* In most hosting accounts, these extensions are enabled by default. But you should check with your hosting provider.

Leave your thought here

Your email address will not be published. Required fields are marked *